import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\+455\\ )(\\d{3})(\\d{1,3})(\\d{1,3})?$";
final String string = "+455 123123123\n"
+ "+455 1111\n"
+ "+455 11121\n";
final String subst = "$1$2 $3 $4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}