using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*[A-Z])(?=.*[a-z])(?=.*\d).{8,}";
string input = @"A1213pokl
bAse730onE
asasasasasasasaas
QWERTYqwerty
123456123456
QwErTy911poqqqq
..........
876876987";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}