$re = '/(?=.*[A-Z])(?=.*[a-z])(?=.*\d).{8,}/m';
$str = 'A1213pokl
bAse730onE
asasasasasasasaas
QWERTYqwerty
123456123456
QwErTy911poqqqq
..........
876876987';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);