#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^category/page-(?![01]$)(?P<page>[0-9]+)$"
Local $sString = "category/page-0" & @CRLF & _
"category/page-1" & @CRLF & _
"category/page-001" & @CRLF & _
"category/page-2" & @CRLF & _
"category/page-2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")