$re = '/^category/page-(?![01]$)(?P<page>[0-9]+)$/m';
$str = 'category/page-0
category/page-1
category/page-001
category/page-2
category/page-2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);