using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Z]+(?![a-z])|[A-Z][a-z]*|\d+[a-z]+";
string input = @"ERISACheckL
ERISA404cCheckL
F401kC
DisclosureG
SafeHarborE";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}