using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(HTTP:\/\/)?([^[:space:]]+).*$";
string input = @"site.com - org name - title
site.net - other name - another title
HTTP://target.ca - ca site - ca title";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}