import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?)\\.(?=(?:[0-9]+\\.){2,}[0-9]+(?:-[a-z]+)?\\.nupkg)(.*?)\\.nupkg$";
final String string = "knockoutjs.3.4.2.nupkg\n"
+ "log4net.2.0.8.nupkg\n"
+ "runtime.tizen.4.0.0-armel.microsoft.netcore.jit.2.0.0.nupkg\n"
+ "nuget.core.2.7.0-alpha.nupkg\n"
+ "microsoft.identitymodel.6.1.7600.16394.nupkg";
final String subst = "Package: $1 Version: $2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}