use strict;
my $str = 'knockoutjs.3.4.2.nupkg
log4net.2.0.8.nupkg
runtime.tizen.4.0.0-armel.microsoft.netcore.jit.2.0.0.nupkg
nuget.core.2.7.0-alpha.nupkg
microsoft.identitymodel.6.1.7600.16394.nupkg';
my $regex = qr/^(.*?)\.(?=(?:[0-9]+\.){2,}[0-9]+(?:-[a-z]+)?\.nupkg)(.*?)\.nupkg$/mp;
my $subst = 'Package: $1 Version: $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";