$re = '/"([^"]+)"/m';
$str = '"DOE, JOHN W","35", "$12,945", "M"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);