#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\+(?=.{15})\d{10,15}_{0,5}$"
Local $sString = "+2345678901_____" & @CRLF & _
"+23456789012____" & @CRLF & _
"+234567890123___" & @CRLF & _
"+2345678901234__" & @CRLF & _
"+23456789012345_" & @CRLF & _
"+234567890123456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")