using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\+(?=.{15})\d{10,15}_{0,5}$";
string input = @"+2345678901_____
+23456789012____
+234567890123___
+2345678901234__
+23456789012345_
+234567890123456";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}