const regex = /^\+(?=.{15})\d{10,15}_{0,5}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\+(?=.{15})\\d{10,15}_{0,5}$', 'gm')
const str = `+2345678901_____
+23456789012____
+234567890123___
+2345678901234__
+23456789012345_
+234567890123456`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}