using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:
"" \s*
(?=
(?: SELECT | FROM )
)
|
(?<! ^ )
\G
)
[^""]*?
\K
( SELECT | FROM ) # (1)
";
string input = @"
SELECT * FROM main -- will not match (not in a string)
""SELECT name FROM main"" -- will match
""
SELECT name FROM main"" -- will match
""""Here is a SQL statement:
SELECT * FROM main"""" -- no, string does not start with a keyword (SELECT...).
""SELECT * FROM table""
""
SELECT * FROM table""
";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}