package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:
" \s*
(?=
(?: SELECT | FROM )
)
|
(?<! ^ )
\G
)
[^"]*?
\K
( SELECT | FROM ) # (1)
`)
var str = `
SELECT * FROM main -- will not match (not in a string)
"SELECT name FROM main" -- will match
"
SELECT name FROM main" -- will match
"""Here is a SQL statement:
SELECT * FROM main""" -- no, string does not start with a keyword (SELECT...).
"SELECT * FROM table"
"
SELECT * FROM table"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}