// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?x)(?:
" \s*
(?=
(?: SELECT | FROM )
)
|
(?<! ^ )
\G
)
[^"]*?
\K
( SELECT | FROM ) # (1)
"#).unwrap();
let string = "
SELECT * FROM main -- will not match (not in a string)
\"SELECT name FROM main\" -- will match
\"
SELECT name FROM main\" -- will match
\"\"\"Here is a SQL statement:
SELECT * FROM main\"\"\" -- no, string does not start with a keyword (SELECT...).
\"SELECT * FROM table\"
\"
SELECT * FROM table\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}