use strict;
my $str = 'Server: Omega-X
celery.queue_length: {\'transfer_data\': \'0\', \'factor_a\': \'0\', \'slow\': \'0\', \'factor_b\': \'0\', \'score_retry\': \'0\', \'damage_factor_c\': \'0\', \'voice_ud\': \'0\', \'alarm_factors_bl\': \'0\', \'telemetry_x\': \'0\', \'endstream\': \'0\', \'celery\': \'0\', \'awl\': \'0\', \'prs\': \'0\', \'score\': \'0\', \'feature_factors_xf\': \'0\', \'feature_factors_dc\': \'0\'}
Server: Alfa-X
celery.queue_length: {\'transfer_data\': \'0\', \'factor_a\': \'0\', \'slow\': \'0\', \'factor_b\': \'0\', \'score_retry\': \'0\', \'damage_factor_c\': \'0\', \'voice_ud\': \'0\', \'alarm_factors_bl\': \'0\', \'telemetry_x\': \'0\', \'endstream\': \'0\', \'celery\': \'0\', \'awl\': \'0\', \'prs\': \'0\', \'score\': \'0\', \'feature_factors_xf\': \'0\', \'feature_factors_dc\': \'0\'}';
my $regex = qr/Server: ([^\n]*)(?:[^{]*)\{(.*)\}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}