const regex = /(((1[0-9]{2})|(2[0-5]{2})|[0-9]{1,2})\.){3}(((1[0-9]{2})|(2[0-5]{2})|[0-9]{1,2}))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(((1[0-9]{2})|(2[0-5]{2})|[0-9]{1,2})\\.){3}(((1[0-9]{2})|(2[0-5]{2})|[0-9]{1,2}))', 'g')
const str = `0.0.0.0
255.255.255.255
256.129.23.5
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}