re = /(((1[0-9]{2})|(2[0-5]{2})|[0-9]{1,2})\.){3}(((1[0-9]{2})|(2[0-5]{2})|[0-9]{1,2}))/
str = '0.0.0.0
255.255.255.255
256.129.23.5
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end