const regex = /(?:\w+|\s){6}(?=moderately)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\w+|\\s){6}(?=moderately)', '')
const str = `this is a test of a moderately long group of words`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}