re = /^([A-PR-UWYZ0-9][A-HK-Y0-9]?[AEHMNPRTVXY0-9]?[ABEHMNPRVWXY0-9]? {0,2}[0-9][A-HK-Y0-9]{1,2}|GIR 0AA)$";/m
str = 'G 83'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end