$re = '/s(.)(.*?.?(?<!\\\\)(?:\\\\\\\\)*)\1(.*?.?(?<!\\\\)(?:\\\\\\\\)*)\1([gimsxr]*?)$/';
$str = 's/\\\\/b/g';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);