#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)Employee:\s*(?P<employee>.+)[\n\r]" & @CRLF & _
"Department:\s*(?P<department>.+)"
Local $sString = "here might be some bla bla as well" & @CRLF & _
"" & @CRLF & _
"Employee: Joe Banana" & @CRLF & _
"Department: Sales " & @CRLF & _
"Location: New York" & @CRLF & _
"" & @CRLF & _
"Bla bla bla" & @CRLF & _
"" & @CRLF & _
"Note:" & @CRLF & _
"" & @CRLF & _
"even more bla"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")