import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Employee:\\s*(?P<employee>.+)[\\n\\r]\n"
+ "Department:\\s*(?P<department>.+)";
final String string = "here might be some bla bla as well\n\n"
+ "Employee: Joe Banana\n"
+ "Department: Sales \n"
+ "Location: New York\n\n"
+ "Bla bla bla\n\n"
+ "Note:\n\n"
+ "even more bla";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}