// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)Employee:\s*(?P<employee>.+)[\n\r]
Department:\s*(?P<department>.+)").unwrap();
let string = "here might be some bla bla as well
Employee: Joe Banana
Department: Sales
Location: New York
Bla bla bla
Note:
even more bla";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}