package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w+(\s\w+){4,}\d+\s+\w+\s+(?:st(?:\.|reet)?|ave(?:\.|nue)?|lane|dr(?:\.|ive)?)
`)
var str = `38246 Luxbury dr
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}