$re = '~(?:https?:)?//.*?(?=$|(?:https?:)?//)~';
$str = 'http://foo.com/barhttps://bar.com//foo.com/foo/bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);