const regex = new RegExp('(mobile\\.|www\\.)?(twitter|x)\\.com([\\w/-]+)', 'g')
const str = `https://twitter.com/lorem
https://www.twitter.com/ipsum
https://x.com/dolor
https://mobile.x.com/sit
https://fedex.com/amet
https://www.fedex.com/consectetur`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}