using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\p{L}+):(?!\1\b)\p{L}+\b";
string input = @"Lôrem:ipsüm dõlör:sït amêt:amêt cønsectetûr:cà ¸nsectetûr âdipiscing:elït";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}