using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\?|\&)(?<key>[\w-]+)(?:\=?|)(?<value>[\w.]+)?";
string input = @".css?v=1.0&active&media=screen&font-weight=normal";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}