re = /(?:\?|\&)(?<key>[\w-]+)(?:\=?|)(?<value>[\w.]+)?/m
str = '.css?v=1.0&active&media=screen&font-weight=normal'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end