re = /^(?:[^@]+\.){5,}[^@]+@(?:[^@]+\.)+[^@]+/
str = 'q.i.n.ghu.im.i.n.g.o.u.r@gmail.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end