#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^==\h*Upgrade Notice\h*==(?:(?:\R(?!=\h*\d+\.\d+\.\d+\h*=$).*)*\R=\h*(\d+\.\d+\.\d+)\h*=$\s*){1}^((?:\h*\S.*(?:\R\h*\S.*)*)+)"
Local $sString = "Some stuff before this notice like a changelog with versioning and explanation text." & @CRLF & _
"" & @CRLF & _
"== Upgrade Notice ==" & @CRLF & _
"" & @CRLF & _
"= 1.3.0 =" & @CRLF & _
"" & @CRLF & _
"When using Master Pro, 1.3.0 is the new minimal required version!" & @CRLF & _
"This is a test" & @CRLF & _
"" & @CRLF & _
"= 1.1.0 =" & @CRLF & _
"" & @CRLF & _
"When using Master Pro, 1.1.0 is the new minimal required version!" & @CRLF & _
"this is" & @CRLF & _
"a test" & @CRLF & _
"" & @CRLF & _
"= 1.0.0 =" & @CRLF & _
"" & @CRLF & _
"No upgrade - just install :)" & @CRLF & _
"another thest" & @CRLF & _
"" & @CRLF & _
"[See changelog for all versions](https://plugins.svn.wordpress.org/master-pro/trunk/CHANGELOG.md)."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")