# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\S)(\w)\s(?=\w\b)/$1/g;t' <<< "Abc defg h i j k, l mn, o p qrst."