import Foundation
let pattern = #"(?<!\S)(\w)\s(?=\w\b)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Abc defg h i j k, l mn, o p qrst."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)