package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^,]+)`)
var str = `abc123,def456,ghi789`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}