#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\B@([^\B ]+)"
Local $sString = "test @hello test"
Local $sSubst = "<a href="profile.php?profile=$1">$0</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)