import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((<br>\\s*)\\1?)+";
final String string = "Addendum 5 changes the following:<div><br><br>\n"
+ "<br></div>div<br>div> Addenda 5 - Landscape\n"
+ "<br>\n"
+ "<br>\n"
+ "<br>\n"
+ "<br>\n"
+ "<br>\n"
+ "<br>\n"
+ "<br>\n"
+ "<br>\n"
+ "<br>\n"
+ "<br>\n"
+ "<br>\n"
+ "<br>\n"
+ "<br>\n"
+ "<br>\n"
+ "<br> \n"
+ "<br>Item\n"
+ "<br>Description\n"
+ "<br>Qty\n"
+ "<br>Unit\n"
+ "<br>";
final String subst = "<br />";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}