# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((<br>\s*)\1?)+"
test_str = ("Addendum 5 changes the following:<div><br><br>\n"
"<br></div>div<br>div> Addenda 5 - Landscape\n"
"<br>\n"
"<br>\n"
"<br>\n"
"<br>\n"
"<br>\n"
"<br>\n"
"<br>\n"
"<br>\n"
"<br>\n"
"<br>\n"
"<br>\n"
"<br>\n"
"<br>\n"
"<br>\n"
"<br> \n"
"<br>Item\n"
"<br>Description\n"
"<br>Qty\n"
"<br>Unit\n"
"<br>")
subst = "<br />"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.