import re
regex = re.compile(r"((?<space>\s+)public\s+static\s+[^(]+\([^)]*?\)\s*\{.*?\k<space>\})|(public\s+static\s+[^(]+\([^)]*?\)\s*\{.*?\n\})", flags=re.DOTALL)
test_str = ("public static FieldsConfig getFieldsConfig(){\n"
" if(xxx) {\n"
" sssss;\n"
" }\n"
" return;\n"
"}\n\n"
"NO CAPTURE\n\n"
"public static FieldsConfig getFieldsConfig2(){\n"
" if(xxx) {\n"
" sssss;\n"
" }\n"
" return;\n"
"}\n\n"
"NO CAPTURE\n\n"
" public static FieldsConfig getFieldsConfig3(){\n"
" if(xxx) {\n"
" sssss;\n"
" }\n"
" return;\n"
" }\n"
" \n"
"NO CAPTURE\n\n"
" public static FieldsConfig getFieldsConfig4(){\n"
" if(xxx) {\n"
" sssss;\n"
" }\n"
" return;\n"
" }")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")