const regex = /((?:<br\s*\/?>)+)|(?<!<br)\s+(?!\/?>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:<br\\s*\\\/?>)+)|(?<!<br)\\s+(?!\\\/?>)', 'g')
const str = `<strong>Blabla1</strong> Blaabla2<br /> Blaabla3 <strong>Blaabla4</strong> Blaabla5 Blaabla6<br /><br /> Blaabla7 <span style='color:#B22222;'>Blaabla8</span> Blaabla9`;
const subst = `$1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);