import Foundation
let pattern = #"((?:<br\s*\/?>)+)|(?<!<br)\s+(?!\/?>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"<strong>Blabla1</strong> Blaabla2<br /> Blaabla3 <strong>Blaabla4</strong> Blaabla5 Blaabla6<br /><br /> Blaabla7 <span style='color:#B22222;'>Blaabla8</span> Blaabla9"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)