re = /\[\d*\]((?=[^"]*(?:"[^"]*"[^"]*)*$)(?=[^']*(?:'[^']*'[^']*)*$))/
str = 'select * as "\'[] [123]\'" from [] where [].[1] = \'[][123]\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end