#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?:\s-)|(?:,\s)|(?:\sand\s)"
Local $sString = "First Filename - 2016-04.pdf " & @CRLF & _
"Second Filename and another name.mp3" & @CRLF & _
"Third.jpg" & @CRLF & _
"Fourth Filename, 2016.pdf" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")