re = /\/(\w+)Box\ \[\ ?([-]?\d+|[-]?\d+\.\d+) +([-]?\d+|[-]?\d+\.\d+) +([-]?\d+|[-]?\d+\.\d+)\ +([-]?\d+|[-]?\d+\.\d+)\ *?\]/m
str = '8 0 obj
<<
/Type /Page
/Parent 3 0 R
/Resources 9 0 R
/Contents [ 40 0 R 42 0 R 44 0 R 51 0 R 53 0 R 55 0 R 57 0 R 59 0 R ]
/TrimBox [ 42 42 2151 1573 ]
/BleedBox [ 36 36 2157 1579 ]
/MediaBox [ 0 0 2194 1615 ]
/CropBox [ 0 0 2194 1615 ]
/Rotate 0
>>
endobj'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end