const regex = /\[{2}([^\W]+)\]{2}\n([^[]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[{2}([^\\W]+)\\]{2}\\n([^[]+)', 'g')
const str = `[[section_abc]]
<div>
several lines of html ...
sdsdoisdoisdosodisodi
<more><a href=""></a>
</div>
[[/section_abc]]
][ [] ][ ]] [[
Example 1
[[ ]] [][] [][
[[section_opq]]
<div>
several lines of html ...
<more><a href=""></a>
</div>
[[/section_opq]]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}