re = /.*匡威.*\W([0-9a-zA-Z\-]{5,})\W/m
str = 'CONVERSE 匡威 男女 CONVERSE ALL STAR系列 Chuck Taylor All Star 休闲鞋 169444C 42码 US8.5码
CONVERSE 匡威 1970S 男女同款 CONVERSE ALL STAR系列 Chuck 70 帆布鞋 167635C 37.5码 US5码
CONVERSE 匡威 1970s 男 女 CONVERSE ALL STAR系列 Chuck 70 休闲鞋 170090C 41码 US7.5码
CONVERSE 匡威 男女 配件系列 CAPS 运动 棒球帽 10018890-A10 OSFA码
CONVERSE匡威官方 All Star 男女鞋高帮运动休闲帆布鞋 1Z588 1Z588/黑色 41/7.5
CONVERSE匡威官方 All Star 男女鞋经典款高帮休闲情侣帆布鞋 101010 101010/黑色 35/3
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end