package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?si)[\w\W]*vimeo\.com\/([\w\W]*)[\w\W]*`)
var str = `http://vimeo.com/123456789`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}