$re = '/[\w\W]*vimeo\.com\/([\w\W]*)[\w\W]*/si';
$str = 'http://vimeo.com/123456789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);