package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{3}(?:(?:[ \.\-]?)\d{2}){3}$`)
var str = `123456789
123 45 67 89
123.45.67.89
123-45-67-89
1234
1341234311341324`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}